Detecting an issue
Incident Report for TrackAbout System
Resolved
Just a brief blip. The situation resolved within seconds.
Posted Nov 08, 2017 - 12:12 EST
Investigating
We're investigating an issue with TrackAbout. More to come.
Posted Nov 08, 2017 - 12:08 EST