Reduced Performance
Incident Report for TrackAbout System
Resolved
We've resolved the temporary performance issues. Site performance should be back to normal.
Posted Mar 23, 2017 - 13:24 EDT
Investigating
We are investigating reports of slowness in the web site and syncing. We believe we've identified the problem and we are taking action to relieve the issue. More information as we have it.
Posted Mar 23, 2017 - 11:54 EDT