Partial outage
Incident Report for TrackAbout System
Postmortem

We’ve been provided the preliminary root cause analysis from Microsoft Azure. The following is from Microsoft Azure:

Summary of impact: Between 06:02 UTC and 07:50 UTC on 08 May 2021, you were identified as a customer using SQL Database in East US 2 who may have experienced issues accessing services. New connections to databases in this subscription in this region may have resulted in an error or timeout. Existing connections remained available to accept new requests, however if those connections were terminated then re-establishing them may have failed.

Preliminary root cause: A backend storage instance became unresponsive and a new primary was not elected. This caused impact to services with dependency on this instance.

Mitigation: The existing primary was powered off which allowed the platform to utilize a new primary. Once completed, the impact to storage and any dependent services was mitigated.

Next steps: We will continue to investigate to establish the full root cause and prevent future occurrences.

Posted May 08, 2021 - 11:28 EDT

Resolved
All systems are now functioning normally. We will continue to investigate root cause and update with a post mortem when we have more information.
Posted May 08, 2021 - 03:55 EDT
Identified
Microsoft Azure is suffering an issue with Azure SQL Database, and our services are impacted. They are taking action to repair. We will update as we know more.
Posted May 08, 2021 - 03:24 EDT
Investigating
Some customers are unable to connect to TrackAbout. We are investigating.
Posted May 08, 2021 - 03:17 EDT
This incident affected: Production Services (Production Application Web Site, Production TAMobile 6 Sync Services).