iOS Login Issue
Incident Report for TrackAbout, Inc.
Resolved
Apple has granted our request for an expedited app review. Version 7.310.76 with the fix should be showing up in the app store within the next 20-60 minutes. Here's a link: https://itunes.apple.com/us/app/trackabout/id530125664

Any customers having issues logging in using iOS devices are advised to update the latest version of the TrackAbout app in the iOS App Store as soon as it shows up in your app store.

This will be the last message regarding this incident and we are marking the incident "Resolved".

We do apologize to any business disruption this incident caused. We have corrected the software build script that caused the problem, so this will not happen again.
Posted 6 months ago. Jan 28, 2019 - 15:25 EST
Monitoring
We have requested an expedited review of the fixed version of our app to the iTunes App Store. There is no guarantee they will accept the request, however. We'll have to wait and see.

To get the word out about this issue we have:

* Opened this incident
* Changed the message on the Login screen of the web site at https://www.trackabout.com/public/login.aspx
* Begun emailing iOS users for whom we have emails to provide instructions for the workaround fix.

All for now.
Posted 6 months ago. Jan 28, 2019 - 11:53 EST
Update
This post on our blog shows screenshots regarding the manual workaround to the issue: https://corp.trackabout.com/blog/fix-for-ios-login-error

We identified the root cause of the problem. The build script for building the iOS version of TAMobile 7 for publishing to the iTunes App Store had a flaw. Due to the fact that we published a patchfix release of iOS, a certain branch of the build script that is seldom used was run. This branch inserted our QA/Test environment's URL into the Settings Hostname field. We have corrected the script to ensure this won't happen again.
Posted 6 months ago. Jan 28, 2019 - 10:09 EST
Identified
We have identified that a recent build of TAMobile 7 iOS went to the iTunes App Store with an incorrect URL override in Settings.

Users updating to the latest version of iOS are not going to be able to log in as a result.

End users can fix the problem themselves. Any users unable to log in should go into Settings change the Hostname field to: www.trackabout.com

This should resolve the login issue.

It may take up to 2 days to get a new version accepted by Apple and published to the iTunes App Store. Their review procedures are unfortunately quite a bit slower than Google's.

We're investigating other possible remedies and will keep updating this incident as we learn more.
Posted 6 months ago. Jan 28, 2019 - 09:37 EST
Investigating
We are currently investigating reports of login failures on iOS. From the login screen, please check the application's built-in Settings link at the bottom. If the "Hostname" field is anything but "www.trackabout.com", change it to "www.trackabout.com" and try to log in again. Other settings on this screen should read Port 443 and Use SSL Encryption ON or Checked.
Posted 6 months ago. Jan 28, 2019 - 08:30 EST
This incident affected: Production Services (TAMobile 7 iOS).