Outbound email delivery issues
Incident Report for TrackAbout System
Resolved
The queued messages from earlier this morning have now all been sent. This issue is resolved.
Posted May 03, 2021 - 11:23 EDT
Monitoring
(Note, the previous communication regarding this issue incorrectly marked this issue as "Resolved".)

Our outbound SMTP email delivery provider temporarily paused our ability to send application email. An overly-broad Alert was configured by an end user and caused over 90,000 emails to be sent.

Our outbound email was paused by our provider at approximately 5:11 AM Eastern US time.

As of 10:25 AM, new emails are being delivered, but emails sent between 5:11 AM and 10:20 AM are stuck in a queue.

Email such as delivery receipts, alerts, password recovery emails and the like were queued, awaiting the release of the mail queue.

We are working to clear the email queue.

We shall also be working on a better Alert email system that does not allow so many individual asset alert emails to be sent, but batches the alerts in a single message.
Posted May 03, 2021 - 05:11 EDT
This incident affected: Production Services (Application-Sent Email Delivery).